PAT

B1016 部分A+B

代码长度限制 16 KB

时间限制 150 ms

内存限制 64 MB

正整数 A 的“D~A~(为 1 位整数)部分”定义为由 A 中所有 D~A~ 组成的新整数 P~A~。例如:给定 A=3862767,D~A~=6,则 A 的“6 部分”P~A~ 是 66,因为 A 中有 2 个 6。

现给定 AD~A~BD~B~,请编写程序计算 P~A~ + P~B~.

输入格式:

输入在一行中依次给出 AD~A~BD~B~,中间以空格分隔,其中 0 < A, B < 10^10^。

输出格式:

在一行中输出 P~A~ + P~B~的值。

输入样例 1:

3862767 6 13530293 3

输出样例 1:

399

输入样例 2:

3862767 1 13530293 8

输出样例 2:

0

Coding:

#include <iostream>
#include <string>
using namespace std;

int main() {
    string A, B;
    int Da, Db;
    cin >> A >> Da >> B >> Db;
    long long Pa = 0, Pb = 0;
    int lenA, lenB;
    lenA = A.size();
    lenB = B.size();
    while (lenA)
    {
        if (A[--lenA] == to_string(Da)[0])
        {
            Pa = Pa * 10 + Da;
        }
    }

    while (lenB)
    {
        if (B[--lenB] == to_string(Db)[0])
        {
            Pb = Pb * 10 + Db;
        }
    }

    cout << Pa + Pb << endl;
    return 0;
}

评论

This is just a placeholder img.