PAT

A1001 A+B Format (20 分)

代码长度限制 16 KB

时间限制 400 ms

内存限制 64 MB

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

Coding:

#include <iostream>
#include <string>

using namespace std;

int main(){
    int a, b;
    scanf("%d%d", &a, &b);
    string c = to_string(a + b);
    int len = c.length();
    for (int i = 0; i < len; ++i) {
        cout << c[i];
        if (c[i] == '-' || i == len - 1)
            continue;
        if ((i + 1) % 3 == len % 3)
            cout << "," ;
    }
    return 0;
}

评论

This is just a placeholder img.