PAT

A1071 Speech Patterns (25 分)

代码长度限制 16 KB

时间限制 300 ms

内存限制 64 MB

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:

Can1: "Can a can can a can?  It can!"

Sample Output:

can 5

Coding:

#include <iostream>
#include <map>
#include <string>

using namespace std;
map<string, int> mp;

bool check(char c){
    if (c >= '0' && c <= '9') return true;
    if (c >= 'a' && c <= 'z') return true;
    if (c >= 'A' && c <= 'Z') return true;
    return false;
}

int main() {
    string words;
    getline(cin, words);
    string s1= "";
    for (int i = 0; i < words.size(); ++i) {
        if (check(words[i])){
            if (words[i] >= 'A' && words[i] <= 'Z'){
                words[i] = words[i] - ('A' - 'a');
            }
            s1 += words[i];
        }
        //else: 如果这里用 if else,pat上最后一组数据无法通过, 因为输入的数据最后一个字符check(c) == true, 没有统计到;
        // || i == words.size() - 1: 这里再加一个判断,判断是否是最后一个字符
        if (!check(words[i]) && s1.size() > 0 || i == words.size() - 1){
            if (mp.find(s1) == mp.end()) {
                mp[s1] = 1;
            } else {
                mp[s1] += 1;
            }
            s1 = "";
        }
    }

    string key = "";
    int max = 0;
    for (map<string, int>::iterator it = mp.begin(); it != mp.end(); it++){
        if (it->second > max ){
            key = it->first;
            max = it->second;
        }
//        cout << "key: " << it->first << ", value: " << it->second << endl;
    }

    cout << key << " " << max << endl;
    return 0;
}

评论

This is just a placeholder img.