PAT

A1100 Mars Numbers (20 分)

代码长度限制 16 KB

时间限制 400 ms

内存限制 64 MB

People on Mars count their numbers with base 13:

  • Zero on Earth is called "tret" on Mars.
  • The numbers 1 to 12 on Earth is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively.
  • For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively.

For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.

Sample Input:

4
29
5
elo nov
tam

Sample Output:

hel mar
may
115
13

Coding:

#include <iostream>
#include <map>
#include <cstdio>
#include <string>

using namespace std;
const int MAX = 170;
string num2mar[MAX];
map<string, int> mar2num;

string num1[13] = {"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct",
                   "nov", "dec"};

string num13[13] = {"tret", "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok",
                    "mer", "jou"};

void init()
{
    //0~12
    for (int i = 0; i < 13; i++)
    {
        num2mar[i] = num1[i];
        mar2num[num1[i]] = i;
    }

    //13, 26 ...
    for (int i = 1; i < 13; i++)
    {
        num2mar[i * 13] = num13[i];
        mar2num[num13[i]] = i * 13;
    }

    string str;
    for (int i = 1; i < 13; i++)
    {
        for (int j = 1; j < 13; j++)
        {
            str = num13[i] + " " + num1[j];
            num2mar[i * 13 + j] = str;
            mar2num[str] = i * 13 + j;
        }
    }
}

int main()
{
    init();
    int N;
    scanf("%d", &N);
    getchar();
    for (int i = 0; i < N; i++)
    {
        string str;
        getline(cin, str);
        if (str[0] >= '0' && str[0] <= '9')
        {
            //num
            int num = 0;
            for (int j = 0; j < str.size(); j++)
            {
                num = num * 10 + (str[j] - '0');
            }
            cout << num2mar[num] << endl;
        }
        else
        {
            printf("%d\n", mar2num[str]);
        }
    }
    return 0;
}

评论

This is just a placeholder img.