A1054 The Dominant Color (20 分)
代码长度限制 16 KB
时间限制 200 ms
内存限制 64 MB
Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.
Output Specification:
For each test case, simply print the dominant color in a line.
Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24
Coding:
#include <iostream>
#include <map>
using namespace std;
map<int, int> mp;
int main() {
int M, N, num;
scanf("%d%d", &M, &N);
for (int i = 0; i < N; ++i) {
for (int j = 0; j < M; ++j) {
scanf("%d", &num);
if (mp.find(num) == mp.end())
mp[num] = 1;
else
mp[num] += 1;
}
}
int key = -1, max = 0;
for (map<int, int>::iterator it = mp.begin(); it != mp.end(); it++){
if(it->second > max){
key = it->first;
max = it->second;
}
}
printf("%d\n", key);
return 0;
}