PAT

A1051 Pop Sequence (25 分)

代码长度限制 16 KB

时间限制 400 ms

内存限制 64 MB

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

Coding:

#include <iostream>
#include <stack>

using namespace std;

const int maxn = 1010;
int arrn[maxn];
stack<int> st;

int main() {
    int M, N, K, num;
    scanf("%d%d%d", &M, &N, &K);
    for (int i = 0; i < K; ++i) {
        while (!st.empty())
            st.pop();

        for (int j = 0; j < N; ++j) {
            scanf("%d", &num);
            arrn[j] = num;
        }
        bool flag = true;
        int temp = 0;
        for (int j = 1; j <= N; ++j) {
            st.push(j);
            if (st.size() > M){
                flag = false;
                break;
            }
            while (!st.empty() && st.top() == arrn[temp]){
                st.pop();
                temp++;
            }
        }
        if (st.empty() == true && flag == true){
            printf("YES\n");
        } else{
            printf("NO\n");
        }
    }
    return 0;
}

评论

This is just a placeholder img.