A1074 Reversing Linked List (25 分)
A1074 Reversing Linked List (25 分)
代码长度限制 16 KB
时间限制 400 ms
内存限制 64 MB
Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.
Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address
is the position of the node, Data
is an integer, and Next
is the position of the next node.
Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
#include <iostream>
#include <vector>
#include <map>
using namespace std;
const int maxn = 100010;
vector<pair<int, int> > temp;
struct Node{
int address, data, next;
}link[maxn];
int main() {
int start, N, K;
int address, data, next;
scanf("%d%d%d", &start, &N, &K);
for (int i = 0; i < N; ++i) {
scanf("%d%d%d", &address, &data, &next);
link[address].address = address;
link[address].data = data;
link[address].next = next;
}
address = start;
while (address != -1){
temp.push_back(make_pair(link[address].address, link[address].data));
address = link[address].next;
}
int group, flag, size = temp.size();
if (size % K == 0) {
flag = 0;
group = size / K;
}
else {
flag = 1;
group = size / K + 1;
}
int pre;
for (int i = 0; i < group; ++i) {
if (i < group - 1) {
for (int j = K - 1; j >= 0; j--) {
if (j > 0)
pre = i * K + j - 1;
else if (j == 0) {
if (i < group - 2 )
pre = K * (i + 1) + K - 1;
else {
if (flag)
pre = K * (i + 1);
else
pre = K * (i + 1) + K - 1;
}
}
printf("%05d %d %05d\n", temp[i * K + j].first, temp[i * K + j].second, temp[pre].first);
}
} else {
if (flag) {
for (int j = K * (group - 1); j < temp.size() - 1; ++j) {
printf("%05d %d %05d\n", temp[j].first, temp[j].second, temp[j + 1].first);
}
printf("%05d %d -1\n", temp[temp.size() - 1].first, temp[temp.size() - 1].second);
} else {
for (int j = K - 1; j >= 0; j--) {
if (j > 0) {
pre = (group - 1) * K + j - 1;
printf("%05d %d %05d\n", temp[i * K + j].first, temp[i * K + j].second, temp[pre].first);
}
else if (j == 0) {
printf("%05d %d -1\n", temp[(group - 1) * K].first, temp[(group - 1) * K].second);
}
}
}
}
}
return 0;
}